Skip to main content
← All vulnerabilities
CVE-2022-4877

snoyberg keter Proxy.hs cross site scripting

Published
Last modified
published
Not listed in CISA KEV
Fix
Fix or patch referenced
None on Exploit-DB, Metasploit or GitHub

Summary

A vulnerability has been found in snoyberg keter up to 1.8.1 and classified as problematic. This vulnerability affects unknown code of the file Keter/Proxy.hs. The manipulation of the argument host leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.8.2 is able to address this issue. The name of the patch is d41f3697926b231782a3ad8050f5af1ce5cc40b7. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217444.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • snoyberg keter

    1.8.0, 1.8.1

References 5

vuldb.com

GitHub · snoyberg/keter