Skip to main content
← All vulnerabilities
CVE-2022-46908BIT-SQLITE-2022-46908

SQLite through 3.40.0, when relying on --safe for execution of an untrusted CLI script, does not properly implement the azProhibitedFunction

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.40.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

SQLite through 3.40.0, when relying on --safe for execution of an untrusted CLI script, does not properly implement the azProhibitedFunctions protection mechanism, and instead allows UDF functions such as WRITEFILE.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • sqliteBitnami

    From 3.37.0 · fixed in 3.40.1

References 5

news.ycombinator.com

sqlite.org

security.netapp.com

security.gentoo.org