Skip to main content
← All vulnerabilities
CVE-2022-45875PYSEC-2023-4GHSA-3XH5-8HVQ-RC8X

Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin

Published
Last modified
published
Not listed in CISA KEV
Low (apache)
Fix
Fixed in 3.0.2, 3.1.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Improper validation of script alert plugin parameters in Apache DolphinScheduler to avoid remote command execution vulnerability. This issue affects Apache DolphinScheduler version 3.0.1 and prior versions; version 3.1.0 and prior versions. This attack can be performed only by authenticated users which can login to DS.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache DolphinScheduler

    From 3.0 · through 3.0.1; From 3.1 · through 3.1.0

  • apache-dolphinschedulerPyPI

    fixed in 3.0.2

  • org.apache.dolphinscheduler:dolphinschedulerMaven

    fixed in 3.0.2

  • org.apache.dolphinscheduler:dolphinschedulerMaven

    From 3.1.0 · fixed in 3.1.1

References 2

lists.apache.org

openwall.com