CVE-2022-44570GHSA-65F5-MFPF-VFHJ
A denial of service vulnerability in the Range header parsing component of Rack >= 1.5.0.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.0.9.2, 2.1.4.2, 2.2.6.2, 3.0.4.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A denial of service vulnerability in the Range header parsing component of Rack >= 1.5.0. A Carefully crafted input can cause the Range header parsing component in Rack to take an unexpected amount of time, possibly resulting in a denial of service attack vector. Any applications that deal with Range requests (such as streaming applications, or applications that serve files) may be impacted.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a https://github.com/rack/rack
Version range not reported
- rackRubyGems
From 1.5.0 · fixed in 2.0.9.2
- rackRubyGems
From 2.1.0.0 · fixed in 2.1.4.2
- rackRubyGems
From 2.2.0.0 · fixed in 2.2.6.2
- rackRubyGems
From 3.0.0.0 · fixed in 3.0.4.1