CVE-2022-43756GHSA-8FCJ-GF77-47MGGO-2023-1515
Rancher/Wrangler: Denial of service when processing Git credentials
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 0.7.4-security1, 0.8.5-security1, 1.0.1, 0.8.11
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
A Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in SUSE Rancher allows remote attackers to cause denial of service by supplying specially crafted git credentials. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- SUSE Rancher
From wrangler · through 0.7.3
- github.com/rancher/wranglerGo
fixed in 0.7.4-security1
- github.com/rancher/wranglerGo
From 0.8.0 · fixed in 0.8.5-security1
- github.com/rancher/wranglerGo
From 1.0.0 · fixed in 1.0.1
- github.com/rancher/wranglerGo
From 0.8.6 · fixed in 0.8.11
- github.com/rancher/wranglerGo
fixed in 0.7.4-security1; From 0.8.0 · fixed in 0.8.5-security1; From 0.8.6 · fixed in 0.8.11; From 1.0.0 · fixed in 1.0.1